Community Forums 

Main Content

Setting up an online payment link for emailed invoices

    Aug 12 2009 19:05:45

    #1

    DaveZ

    Join date : 2009-08-12      Posts : 18

    I currently use a free mals e-commerce account to collect credit card information. It was set up by the programmer of a shopping cart system I use. I now want to expand that service by sending my clients email invoices and then have them click on a link to the same mals account to pay for the invoice. What do I need to do? I don't understand too much coding.

    DaveZ



    Aug 13 2009 05:37:20

    #2

    GT

    Join date : 2008-09-18      Posts : 3212

    How about placing this in html tags...

    <form action="http://ww12.aitsafe.com/cf/pay.cfm"; method="post"> <input type="hidden"
    name="userid" value="E9120065"> <input type="hidden" name="product" value="Invoice number
    12345"> <input type="hidden" name="return" value="www.tne.co.uk/mals/">; <input type="hidden"
    name="qty" value="1"> <input type="hidden" name="price" value="99.99"> <input type="submit"
    value= "Pay my invoice"> </form>

    Having trouble with a form or need one building?
    Fast turnaround, but I do charge :)

    Mal's Forms / Scripts and the syntax are here.




    Aug 13 2009 17:54:34

    #3

    DaveZ

    Join date : 2009-08-12      Posts : 18

    Yes that's the idea I had in mind, create a little form, but how do I populate the form with the correct user information. Just to test, when I replaced the highlighted info with my correct mals account, I got a userid not found error.



    Aug 14 2009 08:01:44

    #4

    GT

    Join date : 2008-09-18      Posts : 3212

    It sounds as though you either or both, put in the wrong ww server number or wrong userid number Dave.

    To use the pay.cfm mode, there are fields you can use:
    https://www.mals-e.com/support/tpv.php?tp=28

    Having trouble with a form or need one building?
    Fast turnaround, but I do charge :)

    Mal's Forms / Scripts and the syntax are here.




    Aug 14 2009 18:48:05

    #5

    DaveZ

    Join date : 2009-08-12      Posts : 18

    I've double checked my userid and server number but I'm stll getting "ERROR userid not set"



    Aug 14 2009 19:44:33

    #6

    Alan

    Join date : 2008-09-18      Posts : 2956

    Can you point to the sample web page that gives the problem?

    Alan
    Some shipping help documents are available at www.stoner.org.uk/mals/




    Aug 14 2009 23:09:31

    #7

    DaveZ

    Join date : 2009-08-12      Posts : 18




    Aug 15 2009 15:18:41

    #8

    Neil

    Join date :      Posts : 0

    There's no user ID in that link, hence the error message.



    Aug 15 2009 20:24:40

    #9

    GT

    Join date : 2008-09-18      Posts : 3212

    Got a page we can look at Dave?

    Having trouble with a form or need one building?
    Fast turnaround, but I do charge :)

    Mal's Forms / Scripts and the syntax are here.




    Aug 15 2009 22:54:18

    #10

    DaveZ

    Join date : 2009-08-12      Posts : 18

    Original error at www.connimage.com/mals-test.html

    Apparently my userid needs to be correct because when I replaced the sample id in your original code with my own actual id, the error changed to a prompt for unpopulated fields

    www.connimage.com/mals-test2.html

    So I still need a way to transfer the correct client information to the mals website.






       1   |   2      »