Community Forums 

Main Content

V2 Shopping Cart 'Remove' Button

    Feb 26 2015 17:22:16

    #1

    Don

    Join date : 2008-09-18      Posts : 487

    In the V2 Shopping Cart it has 2 Buttons 'Update' and 'Remove' - I want to replace the 'Remove' with the 'Trash Can' icon.

    Mal replied to a question I posted on Facebook where he said - I've no plans to use icons, part of the point of version 2 is that it is designed to be mobile friendly. However you could probably add icons yourself using a style sheet, set the icon to the background for the block and the text display to none.

    Does anyone know how to write a Style Sheet script to accomplish this ?

    Any help greatly appreciated.

    DB.

    www.donbarrow.co.uk
    www.pacenotes.com
    Please either Share or Like my Facebook




    Mar 01 2015 17:17:29

    #2

    Geoff

    Join date : 2008-09-18      Posts : 415

    After some experimentation, this seems to work.

    Create a .css file with the folowing

    #cart_items .delete_button {
    background-image: url("https://www.aitsafe.com/ddn/images/icons/delete.gif";);
    background-repeat: no-repeat;
    text-indent: -9999px;
    vertical-align: middle;
    background-color: #FFFFFF;
    width: 100px;
    }

    Name it appropriately e.g. delete_button.css

    Upload it via Cart Setup / Customise / Upload a Style Sheet

    If you want a cross style icon - delete1.gif

    -----------------

    Edited to add - You must remove the extra semicolon that the forum automatically adds to URLs



    Mar 01 2015 19:45:28

    #3

    Don

    Join date : 2008-09-18      Posts : 487

    Geoff, thanks for experimenting - I tested it and afterwards removed it.

    I uploaded the .css and it removed the 'Navy Blue' background and the 'Text' (Remove) but did not import an image delete.gif.

    Am I to create an image delete.gif, if so where do I upload it to ?

    Thanks in anticipation.

    DB

    www.donbarrow.co.uk
    www.pacenotes.com
    Please either Share or Like my Facebook




    Mar 01 2015 21:39:35

    #4

    Geoff

    Join date : 2008-09-18      Posts : 415

    I have tested this so I know it works. Are you sure you removed the extra semicolon that this forum inserts? The one after gif" not the one at the end.



    Mar 01 2015 22:22:16

    #5

    Don

    Join date : 2008-09-18      Posts : 487

    Geoff, brilliant work, I had deleted the wrong ; it all now works OK, many thanks.

    DB

    www.donbarrow.co.uk
    www.pacenotes.com
    Please either Share or Like my Facebook